NovocaineNovocaine09-22 21:43

eclipse安装PyDev插件

首先感谢几位博主的博文。

1.使用eclipse作为python开发工具安装旧版pydev

http://www.cnblogs.com/zhmhhu/p/5867136.html

2.在eclipse中查看eclipse的版本号

https://blog.csdn.net/xiaoye142034/article/details/79720757

3.eclipse插件安装非常缓慢的原因

https://www.javatang.com/archives/2015/05/05/53471232.html

4.关于eclipse安装PyDev后preference下始终没有Pydev选项的解决方案

https://blog.csdn.net/hacker_came/article/details/52120667
博主的eclipse安装的是4.2版本。
我去安装pydev的时候,在perference中始终找不到Pydev选项。上网查了查发现,是pydev插件对eclipse的版本和jdk的版本有要求。在1链接博文下获得了旧版本的链接https://dl.bintray.com/fabioz/pydev/old/
使用旧链接时候,把下图的选项去掉

图

才能显示全部的版本。

关于pydev的本:

Pydev官方的说法是需要安装 java 8 and Eclipse 4.6 (Neon),当然,你也可以选择旧版的Eclipse/Java,但必须符合以下要求:

  • Eclipse 4.5, Java 8: PyDev 5.2.0
  • Eclipse 3.8, Java 7: PyDev 4.5.5
  • Eclipse 3.x, Java 6: PyDev 2.8.2
  • Python 2.5 or older: PyDev 5.5.0
  • Before starting the install

经过测试,Eclipse/Java必须同时高于上述版本,才能安装对应版本的PyDev。例如,eclipse4.3,java6,最高只能安装PyDev 2.8.2。

pydev安装的官方说明

http://www.pydev.org/manual_101_install.html

安装旧版参考:第一个1链接
完毕。

程序之家二维码

000
评论